Modius can be used with operating systems Android 5.0 or higher and/or iOS 9 or higher on both smartphones and tablets.
Was this article helpful?
Cancel
Thank you!